Home / Shop / Routers / TD-W9960 300Mbps Wireless N VDSL/ADSL Modem Router

TD-W9960 300Mbps Wireless N VDSL/ADSL Modem Router

TP-Link

TD-W9960 300Mbps Wireless N VDSL/ADSL Modem Router

Model: TD-W9960

Pricing for this product is provided on request.
Request a quote

300 Mbps wireless N VDSL/ADSL modem router with four Fast Ethernet ports. Combines a DSL modem and a Wi-Fi router for DSL broadband lines.

Specifications

DSL standardsITU-T G.993.2; ITU-T G.993.5 (G.vector); ITU-T G.998.4 (G.INP)
Wi-Fi standardIEEE 802.11b, 802.11g, 802.11n
Interface3 10/100Mbps RJ45 LAN Ports; 1 10/100Mbps RJ45 LAN/WAN Port; 1 RJ11 Port
AntennaOmni directional, Fixed
ProtocolsPPPoE (RFC2516); PPPoA (RFC 2364); MER\IPoE (RFC 1483 Routed); IPoA (RFC1577/2225); Bridge (RFC1483 Bridge)
SecurityNAT Firewall, SPI Firewall, DoS Protection, IP & MAC Binding, Service Filtering, Access Control, Parental Controls
ManagementWeb Based Configuration (HTTP), Remote management, CWMP(TR-069), Web Based Firmware Upgrade, Diagnostic Tools
ModelTD-W9960

Need installation or a bulk quote? Talk to our team.